bmlm is an R package providing convenient methods for Bayesian estimation of multilevel mediation models using Stan.

The package’s source code is hosted on GitHub. More information can be found on the bmlm’s website.

Install

Requirements

Please ensure you have the latest version of R installed. Windows users may need to install RTools (more information on the RStan website), OS X users may need to install XCode (more information).

Install from CRAN

To install the latest stable version of bmlm from CRAN, run

Install from GitHub

Sometimes the stable version on CRAN is not the latest version of bmlm. bmlm is developed on GitHub, and users may obtain the latest (development) version from GitHub directly.

The latest development version of bmlm requires devtools for installation. If you don’t have the devtools package installed in R, first run this line:

Then proceed to install bmlm from GitHub:

devtools::install_github("mvuorre/bmlm", args = "--preclean")

Information

Please contact the author of the package for questions and suggestions. I recommend creating a new issue on GitHub.